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The Index contains a list of all Help topics available for Windows Info-ZIP Unzip. For 
information on how to use Help, press F1 or choose Using Help from the Help menu.



What Is WizUnZip ?

WizUnZip stands for Windows Info-ZIP Unzip. WizUnZip is a Microsoft Windows application 
which extracts, tests, and displays files archived in ZIP archive format.

WizUnZip is derived from a co-operative effort by a number of developers collectively known
as Info-ZIP. (See Who is Info-ZIP ?). Info-ZIP's goal is to provide widely-available, non-
commercial archiving tools compatible with Phil Katz's popular DOS application products, 
pkzip and pkunzip. Info-ZIP's counterpart products are called zip and unzip respectively. 
WizUnZip 2.0 can extract files from archives created using pkzip 2.04 or earlier.

The unzip logic of WizUnZip is based on Info-ZIP's product unzip, which has been ported to a 
number of platforms.WizUnZip is essentially unzip with a Microsoft Windows interface and a 
little extra logic to display and extract files. 

In keeping with Info-ZIP's goals, WizUnZip is available on a not-for-profit basis. (See 
Copyright and Distribution.)



Installing WizUnZip

Install the WizUnZip executable file, WIZUNZIP.EXE, and its associated help file, 
WIZUNZIP.HLP, by copying them into any directory listed in your system's PATH environment
variable. 
Your WINDOWS directory is usually listed there.

Though not necessary for proper operation, the WizUnZip unzipping sound file, 
WIZUNZIP.WAV, may be installed on any directory listed in your system's PATH environment 
variable.
Your WINDOWS directory is usually such a directory.

If you install WizUnZip on a system running Windows 3.0 or OS/2 2.0, you must also install 
the dynamic link libraries COMMDLG.DLL and SHELL.DLL in your WINDOWS\SYSTEM 
directory.
If your system is running Windows 3.1 or Windows NT, these libraries are already present.

If the archive file from which you extracted WizUnZip was named WUNL20.ZIP, these 
libraries are included.
To save space, these libraries are not included in the archive named WUNZ20.ZIP.



Edit Menu

The Edit menu includes commands that let you select or de-select all of the listbox entries or
to control the Status Window.

For more information, select an Edit menu command from below.

Select All Files Selects all listbox entries.
De-select All Files De-selects and unhighlights all listbox entries.
Select Files by Pattern... Selects filenames by pattern.

Clear Status Window Clears the contents of the Status Window.
Copy Status Window to Clipboard Copies the entire Status Window to the Windows 

clipboard.



De-select All Files

This menu item de-selects and unhighlights all entries in the listbox. 

WizUnZip dims the three buttons Extract, Display, and Test. 

You may then select one or more entries in the listbox using the pointer or the keyboard. 

Selecting one or more entries in the listbox causes the buttons to become active again. 

Select any of the buttons to operate on the selected entries.

Pressing the F3 key is a short-cut to de-selecting all listbox entries.



Select All Files

This menu item selects and highlights all entries in the listbox. 

WizUnZip activates the three Extract, Display, and Test buttons. 

Select any of the three buttons to operate on all selected entries in the archive.

Pressing the F2 key is a short-cut to selecting all listbox entries.



Select Files By Pattern

When archives contain a large number of files, you can select the files to be extracted by 
specifying patterns in the filenames. 

This menu item opens the Select Files by Pattern dialog box. It prompts you to enter a 
pattern by which files in the Archive Directory Listbox are selected. 
Your pattern may contain wild card characters such as *, ?, and character lists surrounded by
square brackets.
You may enter multiple patterns, separated by white space, in the edit field.
Choose the Select button to highlight your choices in the ArchiveDirectoryListbox. 
The files can then be extracted, displayed, or tested using any of the three pushbottons. 

You may alternately deselect files in the listbox by first specifying a pattern then choosing 
the Deselect button.

After making all your selections and deselections, you may wish to close the dialog box by 
selecting the Done button. 

Pressing the F4 key is a short-cut to the Select Files by Pattern dialog box.



Clear Status Window

This menu item clears the Status Window.

WizUnZip automatically clears your Status Window if its contents would either exceed the 
amount of global memory space available in your system or reach 65535 characters.

Pressing the Del key is a short-cut to clearing the Status Window.



Copy Status Window to Clipboard

This menu item copies the entire contents of the Status Window to the Windows clipboard.

Currently there is no way to copy a portion of the Status Window to the Windows clipboard.

The Control-C key sequence is a short-cut which copies the Status window to the clipboard.



File Menu

The File menu includes the following commands:

File Menu "Open..." Command Opens an archive and lists its directory.
File Menu "Unzip To..." Command Changes the directory where WizUnZip places

extracted entries.
File Menu "Exit" Command Exits WizUnZip.



File Menu "Open..." Command

The File menu's Open command brings up the Open ZIP File dialog box.

Open ZIP File Dialog Box

This dialog box lets you select the ZIP archive on which you may perform further operations.
Select the directory in which the ZIP archive is found.
When you select a directory,    WizUnZip lists all of the Zip archives, files with suffix .ZIP, in 
the listbox.
The File Name field starts out as a template of all the ZIP archives in the directory.

You may select archives with other suffixes using the List Files of Type combo box. 
You may select self-extracting .ZIP files, which have the .EXE suffix. 
However, not every file with a .EXE suffix is a self-extracting .ZIP file.
WizUnZip lets you safely attempt to open the file to find out.

Select an archive either by clicking on its filename from the listbox or by typing its name in 
the File Name edit box.
Select the OK button to put your choice into effect.

Select the Cancel button if you don't wish to open a new ZIP archive.

When you open a ZIP archive, WizUnZip displays the archive contents in the Archive 
Directory Listbox of its main window. 
WizUnZip does not automatically extract the contents.    See Extracting Files from the 
Archive to find out how to do this.

You may unzip the archive contents either into the directory where the .ZIP file lives or into a
separate directory.
See the File Menu Unzip To Command and the Unzip to Same Directory as .ZIP item under 
the Options Menu for more information.



File Menu "Unzip To..." Command

This command lets you change the directory into which WizUnZip extracts entries from the 
current ZIP archive.
You may extract files into a directory other than the one in which the ZIP archive file resides.

If this command is grayed, you may enable it by toggling the Unzip to Same Directory 
as .ZIP item under the Options Menu.

If you don't select a destination directory, WizUnZip assumes you wish to extract files into 
the same directory as the ZIP archive.
The "Unzip To..." command produces the Unzip To Dialog Box.

Unzip To Dialog Box

This dialog box lets you browse and select a destination directory for unzipped archive 
entries.

The Directories listbox shows where WizUnZip will place extracted files.

You may browse the directory tree by repeatedly selecting directories from the Directories 
listbox.

To automatically change to the selected directory the next time you start WizUnZip, select 
the Save as Default checkbox.

Select the OK button to save the new directory as the one to which WizUnzip extracts files.    
The new destination directory is shown in the title bar.

Select the Cancel button to return to the directory displayed on entry.

NOTE:
The Drives listbox shows all drives in the system. 
However, you won't be able to select write-protected drives such as CD-ROM drives and 
some network drives.



File Menu Exit Command

This command takes you out of WizUnZip. 
To find out other ways to exit WizUnZip, see Exiting WizUnZip.



Exiting WizUnZip

You may exit WizUnZip by any of the following methods:
1) typing Alt-F4, 
2) selecting Exit from the File menu, or 
3) selecting Close from WizUnZip's system menu.

You may safely exit WizUnZip at any time without fear of losing data.



Options Menu

The Options menu lets you specify how WizUnZip handles directories, whether or not 
WizUnZip should overwrite existing files during extraction,    what WizUnZip does when you 
select one or more files in the listbox, and to where WizUnZip extracts files from the archive.

For more information, select any of the following four items:

Recreate Directory Structure Lets you extract subdirectories or not.
Overwrite Existing Files Controls overwriting existing files.
Translate LF to CR-LF Translates LF character to CR/LF character pair.
Unzip to Same Directory as .ZIP Controls whether you unzip in .ZIP or other 
directory.

The following three items let you define the action taken when you double-click on a file in 
the listbox: 

Listbox Selection Extracts File Double click extracts entry.
Listbox Selection Tests File Double click tests entry.
Listbox Selection Displays File Double click displays entry in Status Window.

Sound Options Selects sound at start or end of operation.

Clear Status Window Before Displaying Clears the Status Window before displaying the 
selected file or files.

WizUnZip saves your option selection permanently until you replace it with another.



Recreate Directory Structure

During file extraction this option specifies whether or not WizUnZip re-creates subdirectories 
saved within the archive. 

When this option is active, a checkmark appears beside its menu item.

When this option is active, WizUnZip extracts, preserving the directory structure present in 
the archive.

When this option is not active, WizUnZip extracts the files from subdirectories listed in the 
archive into the parent directory.

WizUnZip saves the setting of this option in your WIZUNZIP.INI file until you change it again 
through the menu.



Overwrite Existing Files Option

When you choose this option, WizUnZip automatically overwrites each existing file that it 
finds during extraction. 
WizUnZip places a check mark beside the menu item to show that the option is in force.

WizUnZip saves the setting of this option in your WIZUNZIP.INI file until you change it again 
through the menus.

Overwrite Existing Files Dialog Box

When you don't choose the Overwrite Existing Files option, WizUnZip prompts you with a 
dialog box for each existing file that it would replace during extraction. The dialog box 
prompt gives you five alternatives.    You may:

1) skip the file without extracting it (the default),
2) overwrite the file,
3) overwrite the file and all others in this operation,
4) overwrite none of the files in this operation,
5) rename the conflicting file.

If you select 3) or 4), the Overwrite Existing Files Dialog Box won't appear for the rest of the 
operation if any more files should conflict with existing files.
The Overwrite Existing Files Dialog Box has no effect on the more permanent Overwrite 
Existing Files Option.



Translate LF to CR-LF

Choose this option only if you are extracting text files from a UNIX or similar computer and 
wish to translate them into the format used by DOS.    
In UNIX text file format, lines of text are separated by a linefeed character. 
Lines of text within DOS files are typically separated by the two characters:carriage return, 
linefeed.

Do not choose this option if you are extracting a binary file.    
Since WizUnZip can't tell the difference between text and binary files, you have to decide 
when to use it.    
In general, don't choose this option unless you're sure you need it.

WizUnZip places a check mark beside the menu item to show that the option is in force.    
The setting you choose stays in effect until you toggle it.



Unzip to Same Directory as .ZIP

Choose this option only if you want WizUnZip to always extract the contents of the ZIP 
archive in the same directory as the ZIP archive.    
This option saves having to set the extraction directory separately. 

When WizUnZip is set to unzip in the same directory as the ZIP archive, WizUnZip disables 
and grays the File Menu "Unzip To..." Command.

When you do not select this option, WizUnZip enables the File Menu "Unzip To..." Command, 
and you may select the destination directory.

WizUnZip places a check mark beside the menu item to show that the option is in force.    
The setting you choose stays in effect until you toggle it.

WizUnZip's title bar always shows the name of the directory into which it extracts regardless
of the option's setting.



Listbox Selection Extracts File

When this option is active, double-clicking on a listbox entry extracts the selected entry from
the archive and logs the outcome in the Status Window.



Listbox Selection Displays File

When this option is active, double-clicking on a listbox entry displays the entry in the Status 
Window. 



Listbox Selection Tests File

When this option is active, double-clicking on a listbox entry tests the entry and displays the 
results in the Status Window. 



Sound Options

This entry leads to a dialog box in which you choose the sound that WizUnZip emits either 
before or after the action (i.e. extract, test or display entries) completes. 
If WizUnZip detects that the system can play a wave, you may specify the name of a wave 
file which WizUnZip plays either before or after the operation. 
WizUnZip includes a default wave file, WIZUNZIP.WAV, which contains an unzipping sound. 

Regardless of whether your system can play wave files, you can configure WizUnZip to emit 
a beep on completion.

The Browse option lets you search for .WAV files on your system.

The Play option plays whichever .WAV file is shown in the Sound Name or File edit field.



Clear Status Window Before Displaying

This option makes it easier to view the contents of any text file within the archive by first 
clearing the Status Window.

When this option is active, WizUnZip also positions the Status window to the top of the 
extracted file rather than at its end when displaying.



View Menu

The View menu directs WizUnZip to display the archive contents in either Long Format or 
Short Format.

WizUnZip places a check mark beside the menu item corresponding to the archive directory 
listbox format which is currently selected.

You may also modify the relative sizes of the Archive Directory Listbox and    the Status 
Window by selecting Maximize Archive Directory Listbox, Maximize Status Window, or Split.

WizUnZip places a check mark beside the menu item corresponding to the screen layout 
which is currently selected.



Long Format

In long format WizUnZip's Archive Directory Listbox shows:

the file length in Kbytes before archiving,
the ZIP method of archiving: e.g. deflating, imploding, storing, shrinking, reducing.
the file size in Kbytes within the archive,
the compression ratio,
the file modification date,
the file modification time,
the 32-bit cyclic redundancy check value, used for integrity checking,
the file name.



Short Format

In short format WizUnZip's Archive Directory Listbox shows:

the file length in Kbytes before archiving,
the file modification date,
the file modification time,
the file name.



Maximize Status Window

This menu item maximizes the Status Window so that it covers the Pushbuttons and the 
Archive Directory Listbox.    This makes it easier for you to browse a file displayed from the 
archive.

You can restore the Status Window by selecting the Restore entry from its system menu, by 
double-clicking its maximize/minimize icon in its upper right-hand corner, or by Selecting the
Split menu item under the View menu.



Split

This menu item restores the Archive Directory Listbox and Status Window to their original 
sizes.



Maximize Archive Directory Listbox

This menu item maximizes the Archive Directory Listbox, covering the Status Window. This 
makes it easier for you to view archives with many entries.

You can restore the Archive Directory Listbox by selecting the Split menu item under the 
View menu.



Glossary

DOS
FTP
Internet
UNIX
ZIP archive



DOS

The DOS operating system popular on IBM-compatible personal computers.
It's probably running on your PC right now.
DOS usually is short for MS-DOS, a trademark of Microsoft.



FTP

File Transfer Protocol. A protocol for transferring files through the Internet.



Internet

A data network connecting many universities, corporations, and government institutions.



UNIX

The UNIX operating system is popular on multi-user open computer systems.    Unix is a 
trademark of AT&T.



ZIP archive

A ZIP archive is a collection of files stored within a single file in the format implemented by 
Phil Katz's products pkzip and pkunzip as well as Info-ZIP's products zip and unzip. ZIP 
archive files typically have the suffix .ZIP. 

WizUnZip is compatible with archives created by pkzip version 2.04 and earlier.



Browsing Text in the Archive

To browse one or more files within the archive, first select the files using the listbox then 
select the Display Button either by clicking on it or by typing Control-D.    
The selected entries will be displayed in the Status Window which can be scrolled using the 
horizontal and vertical scroll bars.

Alternately, you may use the Options menu to let you automatically display a file whenever 
you select its entry in the listbox.    
To do so, select the Listbox Selection Displays File. from the Options menu.    
Whenever you double-click on a entry in the listbox, WizUnZip will display the entry's 
contents in the Status Window. 
WizUnZip saves this setting in your WIZUNZIP.INI file until you change it.

WizUnZip cannot distinguish between text and binary data files, so it is possible to display a 
binary data file into the Status Window. 
WizUnZip assumes that the files it displays in the Status Window are in the PC 
manufacturer's OEM codepage, which WizUnZip translates to the ANSI character set. 



Extracting Files from the Archive

First select the files you wish to extract, using the Archive Directory Listbox . 
Next select the Extract Button by clicking on it or by typing Control-X.    
WizUnZip extracts the files, placing them in the current directory. 
The Status Window lists the names of the files as they are extracted.

Alternately, you may use the Options menu to let you automatically extract a file whenever 
you double-click on an entryin the listbox.    To do so, select the Listbox SelectionExtracts 
File. from the Options menu.    
Now when you double-click on an entry in the listbox, WizUnZip will extract it. WizUnZip 
saves this setting in your WIZUNZIP.INI file until you change it.



Testing Files in the Archive

First select the files you wish to test, using the Archive Directory Listbox. Next select the Test
button by clicking on it or by typing Control-T.    WizUnZip tests the files, listing the file names
and results as they are tested.

Alternately, you may use the Options menu to let you automatically test a file whenever you 
double-click on an entry in the listbox.    To do so, select Listbox Selection Tests File  from the 
Options menu.    Afterwards, when you double-click on an entry in the Archive Directory 
Listbox, WizUnZip will test it. WizUnZip saves this setting in your WIZUNZIP.INI file until you 
change it.



Opening an Archive File

Before WizUnZip can operate on an ZIP archive, you must open an archive file. 
WizUnZip only operates on archive files in .ZIP format. .ZIP files are created either by Phil 
Katz's PKZIP program or by Info-ZIP's ZIP program. 
ZIP files are identified by their .ZIP suffix.

You may open a .ZIP file using various methods including:
1) Passing its name to WizUnZip when you start WizUnZip or,
2) Using WizUnZip's File Menu Open Command or,
3) Dragging the file from the File manager and dropping the file on to 
          the WizUnZip window.

You may find it useful to let Windows' File Manager associate the .ZIP suffix with WizUnZip 
for easy browsing and extraction of .ZIP files.

When the archive file has been successfully opened, its name appears in WizUnZip's title 
bar. 
From that point forward, WizUnZip's listbox and button operations apply to the open file. 
WizUnZip can open only one .ZIP file at a time. 
It is not necessary to close or save the file before exiting WizUnZip.



Showing the Archive Comment

Some ZIP archive files contain a readable comment. If you have opened an archive which 
has a comment, the Show Comment button will be active. If the archive has no comment, 
then the Show Comment button will be grayed.    You may display the comment by selecting 
the Show Comment button with the mouse or by typing Control-S. 

The comment will be copied to the Status Window where it may be scrolled using the scroll 
bars or the standard Windows navigation keys. 



Archive Directory Listbox

When you open a ZIP archive, WizUnZip displays the archive's directory in the Archive 
Directory Listbox at the top of WizUnZip's main window. The contents may be displayed in 
either Long Format or Short Format using the View Menu. The format of the listbox entries 
will be familiar to users of Phil Katz's PKUNZIP program or Info-ZIP's UNZIP program.

The Archive Directory Listbox is an extended, multiple-selection listbox.
This means you may select multiple files by clicking the mouse on a given item and 
dragging the mouse downward through the listbox.
You may also press the Control key and click on listbox individual items to make a 
cumulative list.
To select or de-select all files in the listbox at once, use the Edit Menu.

After selecting the files on which you wish to operate, complete the operation by selecting 
either the Extract Button, the Display Button, or the Test Button.

You may extract, display, or test files directly from the listbox by double-clicking on the 
entries in the listbox. To define which action WizUnZip takes when you double-click on an 
entry, use the Options Menu. The pushbutton which corresponds to the listbox double-click 
action is surrounded by a thicker frame.

Background Color

The background color of the Archive Directory Listbox heading and total area is the Windows
Disabled Text color.
You can change your system's Disabled Text color using the Windows Control Panel.
Be careful! If you set your system's Disabled Text color to the same color as regular text 
(e.g. black), you won't be able to see the headings and totals above and below the listbox.



Push-buttons

Below the archive directory listbox in WizUnZip's main window are four push buttons which 
let you access the contents of the .ZIP archive opened earlier.

The pushbutton which corresponds to the listbox double-click action is surrounded by a 
thicker frame.



Display Button

When active, the Display button copies the selected files shown in the listbox into the Status
Window. 



Extract Button

When active, the Extract button unzips the selected entries in the listbox into the current 
directory. 



Test Button

When active, the Test button checks the integrity of the selected entries in the listbox and 
displays the outcome of the check in the Status Window. 



Show Comment Button

When active, the Show Comment button displays the contents of the archive comment in 
the Status Window where you may browse it. 



Status Window

At the bottom of WizUnZip's main window is the Status window, in which WizUnZip displays 
three types of information from the archive:

1) a record of file extraction and file testing (see Extracting Files from the Archive),
2) text files to browse (see Browsing Text in the Archive),
3) comments (see Showing the Archive Comment).

The Status window may be scrolled horizontally or vertically using either the mouse or 
standard Windows navigation keys.

You can maximize the Status window within WizUnZip's main window by clicking on the 
Status window's maximize box or by selecting the Maximize entry from the Status window's 
system menu.    When maximized, the Status window covers the listbox and Pushbuttons.

You can restore the maximized Status window to its normal size by clicking on the Status 
window's maximize box again or by selecting the Minimize entry from the Status window's 
system menu.

You can hide the Status window by selecting Maximize Archive Directory Listbox from the 
View Menu.    To show the Status window, select Split from the View menu.

You can clear the Status window using the Clear Status Window menu item from the Edit 
Menu or by typing the Del key.    The Status window automatically clears itself to make room 
for more information when either of the following happens:

1) the number of characters in the buffer reaches 65535, or
2) your system does not have enough global memory to store more data.



Title Bar

The title bar shows which ZIP archive is currently open and into which directory WizUnZip 
will extract archive entries.

If no ZIP archive is open, the title bar contains the message (No ZIP File) in the file name 
field.



Icon
The WizUnZip icon's title includes the name of the current archive file name. 
If no ZIP archive is open, the title contains the text (No ZIP File).

The WizUnZip icon starts out as a fully zipped zipper.

After extracting the first file, the WizUnZip icon changes into an unzipped zipper.

That's as close as WizUnZip comes to snappy graphics and animation.

The icon artwork is by Becky Cobb.



Becky Cobb

"No one can do
      What Becky can do
In just thirty-two
      By thirty-two."



Error Messages in the Status Window

This section describes some of the error messages which can appear in the Status Window.

filename:    encrypted (can't do yet)--skipping.
This message indicates an encrypted file was found in the archive. Since decryption is not 
supported in the current version of WizUnZip, the file is skipped.

End-of-central-directory signature not found.    Either this file is not
          a zipfile, or it constitutes one disk of a multi-part archive.    In the
          latter case the central directory and zipfile comment will be found on
          the last disk(s) of this archive.
This error means that the opened file is either not in ZIP archive format or is a corrupted ZIP 
file.    Check the suffix of the file. This error might occur if you transferred the archive across 
a network as an ASCII file rather than as a binary file. At any rate, WizUnZip can't decipher 
it.

error: can't open zipfile [ filename ]
This message appears if the archive file has been moved or deleted after having been 
opened in WizUnZip.

error:    expected central file header signature not found (file #n).
This error means that the opened file is either not in ZIP archive format or is a corrupted ZIP 
file.    Check the suffix of the file. This error might occur if you transferred the archive across 
a network as an ASCII file rather than as binary file. At any rate, WizUnZip can't decipher it.

Expanding: filename    status
Exploding: filename    status
Extracting: filename    status
Inflating: filename    status
Testing:filename    status
UnShrinking:filename    status
These messages occur during extraction or testing. During extraction they indicate which 
compression technique was employed to archive the file named filename.    The status value 
can be either 

OK,    which means success, 

or

Bad CRC xxxxxxxx    (should be xxxxxxxx), which means the file is corrupted in the 
archive,

where xxxxxxxx is a hexadecimal number.

Fatal write error
This message might appear if the disk had filled up while extracting a file.

filename    unknown compression method
This indicates that WizUnZip cannot extract the given file. The cause is possibly due to a 
corrupted archive or the file was stored using a technique designed after this version of 
WizUnZip.

warning:    didn't find end-of-central-dir signature at end of central dir.
This error indicates that the opened file is either not in ZIP archive format or is a corrupted 



ZIP file.    Check the suffix of the file. This error might occur if you transferred the archive 
across a network as an ASCII file rather than as a binary file. 

warning:    filename too long--truncating
This error might appear when extracting a file generated on a system other than DOS. The 
name exceeds DOS's 8.3 format.



Error Messages in Dialog Boxes

This section describes error messages which may appear in a Windows message box.

A write error has occurred. Perhaps the disk is full. Continue ?
Appears during extraction. It typically occurs if the disk to which you are extracting runs out 
of free space. Files may erroneously appear to have CRC errors during extraction in this 
case.    It typically does no good to continue.

Cannot open filename
Appears in the Open a ZIP File dialog box if you specify a file that doesn't exist.
Can also appear if you specify a file which does not exist when starting up WizUnZip with a 
filename argument.

Can't change directory to <directory name>!
Appears before or after extraction if WizUnZip has been configured to change to or return to 
a non-existent directory.

Clearing Messages window to make room for more information.
Appears if the Status Window buffer becomes full or otherwise cannot grow.

johnny__.yuu. Cannot access this file. Please verify security priveleges on the 
network drive.
This message box appears if you try to select a write-protected drive, such as a CD-ROM 
drive, from the Unzip To... dialog box.
(See File Menu "Unzip To..." Command.)

This archive contains too many files for WizUnZip to list them all! 
This appears if the archive contains many files and the data required to list those files and 
their attributes exceeds a Windows internal limit of 65K characters.



Who is Info-ZIP ?

This is a partial list of contributors to Info-ZIP UnZip and the code upon which it is based.
Many, many others have also contributed, and if you are among them, please let us know.
Aside from the Info-ZIP digest archives,we have not kept very good track of who contributed 
what.

Mark Adler decryption code; inflate, explode, funzip code; misc. casts
Glenn Andrews MSDOS makefiles; prototyping bugfix
Joel Aycock descrip.mms bugfix
Allan Bjorklund in misc.c
James Birdsall extract.c bugfix; etc.
Wim Bonner OS/2 stuff
John Cowan mods to original match.c; other stuff?
Frank da Cruz xxu.c, on which mapname.c is based
Bill Davidsen -q(q); mapname stuff; memset/memcpy(?); etc.
Arjan de Vet various things, but I don't remember exactly what...
James Dugal ZMEM stuff; unshrink bugfix; file perms stuff; etc.
Jim Dumser -z stuff; umask bugfixes; etc.
Mark Edwards in mapname.c, misc.c
David Feinleib Windows NT port
Mike Freeman VMS GCC makefiles; etc.
Jean-loup Gailly decryption code; much prodding to fix bugs :-)
Hunter Goatley VMS RUNOFF source (documentation)
Robert Heath original Windows port, WizUnZip 2.0
Dave Heiland new usage screen [, new documentation...?]
Larry Jones ZMEM stuff; unimplod bugfix; etc.
Kjetil Jørgenson ln/copy misc_.c bugfix
J. Kercheval filmatch.c, on which match.c is based
David Kirschbaum mapname port; general-purpose meddling; Python jokes
Alvin Koh Borland C++ bugfixes
Bo Kullmar -z code; bugfixes: umask, do_string, BSD time; etc.
Johnny Lee Macintosh port; 5.0 Mac resource fork stuff; Win3.1 port
Warner Losh in misc.c
Igor Mandrichenko vms.c; many improvements and VMS modifications
Fulvio Marino revised Unzip and ZipInfo man pages
Carl Mascott original Unix port
Gene McManus -o code
Joe Meadows file.c, on which VMSmunch.c is based
Mike O'Carroll OS/2 stuff
Humberto Ortiz-Zuazaga Linux port; permissions bugfix; missing declarations
Keith Petersen former Info-ZIP list maintainer
Piet W. Plomp nice fix for msc_dos Makefile target
Antonio Querubin, Jr descrip.mms (VMS makefile)
Greg Roelofs central directory code; ZipInfo; original VMS port;...
Kai Uwe Rommel much OS/2 code; bugfixes; etc.
Steve Salisbury CountryInfo bugfix; variable INBUFSIZ
Georg Sassen Amiga DICE compiler port
Jon Saxton date formats
Hugh Schmidt VMS stuff
Martin Schulz Atari patches
Charles Scripter various bug reports and bugfixes
Chris Seaman Unix time stuff
Richard Seay MS-DOS Quick C makefile
Alex Sergejew file_io.c bugfix; stat() bugfix; Down Under jokes



Samuel H. Smith original unzip code (Pascal and C) for PC
Cliff Stanford file_io.c umask bug
Onno van der Linden SCO optimization bugfix; etc.
Antoine Verheijen MTS/EBCDIC stuff; FILENAME_MAX stuff; Mac fixes; etc.
Rich Wales current Info-ZIP moderator and zip guy
Paul Wells original Amiga port for SAS/C and Lattice C (?)



Copyright and Distribution

===========================================
The following copyrights are claimed on portions of the UnZip source code.
Further comments are at the bottom.
===========================================
Copyright in unzip.c, originally from unzip version 1.2 (?):

* Copyright 1989 Samuel H. Smith;    All rights reserved
*
* Do not distribute modified versions without my permission.
* Do not remove or alter this notice or any other copyright notice.
* If you use this in your own program you must distribute source code.
* Do not use any of this in a commercial product.

-------------------------------------------------------------------------------

Copyright in misc.c, applying to UpdateCRC() and crc_32_tab[]:

COPYRIGHT (C) 1986 Gary S. Brown. You may use this program, or code or tables 
extracted from it, as desired without restriction.

-------------------------------------------------------------------------------

Copyright in vms.c, distributed with UnZip versions 4.2 and later:

* Copyright (C) 1992 Igor Mandrichenko.
* Permission is granted to any individual or institution to use, copy,
* or redistribute this software so long as all of the original files
* are included unmodified, that it is not sold for profit, and that
* this copyright notice is retained.

-------------------------------------------------------------------------------

Additional copyright information:

BILF (distributed with the VMS stuff) is copyrighted by Rahul Dhesi, but it is freely 
distributable.

The functions extract_or_test_files() and store_info() in extract.c, do_string() and 
return_VMS() in misc.c, VMS version of echo() in file_io.c, and find_end_central_dir() in 
unzip.c, were written by Greg Roelofs and subsequently modified by many others via Info-
ZIP. I do not claim a copyright on these routines, but I do ask that no one else do so 
either, :-) and that anyone using them in other programs note their source.

The function decrypt_member() in extract.c and the password functions in file_io.c were 
written by Mark Adler, as were the inflate.c and explode.c modules.

The function mapped_name() in mapname.c was written by David Kirschbaum, based on the
XXU program by Frank Da Cruz.

The module match.c was written by J. Kercheval and modified by David Kirschbaum for use 
in UnZip.

Original notes from unzip 2.0a by Carl Mascott, cmascott@world.std.com (these are only the 



modifications which seem still to exist):
* 12/14/89 C. Mascott    2.0a      adapt for UNIX
* don't pre-allocate output file space
* implement -t, -v, member file specs
* buffer all input
* fix "Bad CRC" msg: good/bad CRCs were swapped
* check for write error on output file

Most of the remaining routines have contributions from all of us, and show it. :-)

===========================================

Info-ZIP comments:

Info-ZIP has very little interest in legal matters, aside from the usual "CYA" sense (that's an 
acronym, and you can figure it out yourself :-) ).

As far as we are aware--and please note that the numerous contributors and copyright 
holders make this a little uncertain--the UnZip code is now "clean" in the sense that an 
UnZip executable may be distributed with a commercial product SO LONG AS IT IS CLEAR 
THAT UnZip IS NOT BEING SOLD, THAT THE SOURCE CODE IS FREELY AVAILABLE, 
AND THAT THERE ARE NO EXTRA OR HIDDEN CHARGES RESULTING FROM ITS USE 
BY OR INCLUSION WITH THE COMMERCIAL PRODUCT.    In particular, the retroactive 
copyright on unimplode.c which Carl Mascott requested we include in UnZip 4.2 is no longer 
in force, since Mark Adler has rewritten the module in question from scratch (it's about twice
as fast, too! :-) ).

Regarding the original copyright by Mr. Smith:    Info-ZIP has finally found him again (he's 
moved to southern California), and he's apparently happy with the current code and 
restrictions.    More specifically, since the current incarnation of UnZip can be considered "our
own"--it bears very little resemblance to his original program, in either content or size :-)
--and since we freely distribute the source code, we believe that we are within the bounds of
his third stipulation.

Info-ZIP continues to rewrite portions of the code as time permits, in an effort to eliminate as
many of the restrictions (and bugs) as possible.    The bugs are our primary concern, 
however, so don't hold your breath. :-)

I Place My Portion in the Public Domain

The Info-ZIP developers have chosen not to copyright unzip.
I, Robert A. Heath, am the author of the Microsoft Windows interface version of UNZIP, which
I call WizUnZip. 
I place the portion which I wrote in the public domain. 
I give you my permission to distribute my portion without condition. (It's free!    No charge!)
You may make derivative works from the source. 

Johnny Lee: Ditto. ;-) 

The MS Windows-specific sources for WizUnZip 2.0 are archived under wunz20sr.zip on 
popular archive sites.

Where to Find Info-ZIP Products
Info-ZIP products are available on many well-known Internet hosts. Anonymous ftp can be 



used to retrieve Info-ZIP's utilities from most of the large archive sites (Simtel, garbo, 
oak.oakland.edu, wuarchive, etc.).

Some current products available on oak.oakland.edu:

/pub/msdos/zip/unz50p1.zip (unzip source)
/pub/misc/unix/unz50p1.tar-z (unzip source)
/pub/msdos/zip/unz50p1.exe(unzip MSDOS exe)

/pub/msdos/zip/zip19p1.zip (zip source)
/pub/msdos/zip/zip19p1x.zip(zip MSDOS exe)

ZIP 1.9 and UNZIP 5.0p1 have been submitted to comp.sources.misc. One should be able to 
FTP the sources for ZIP 1.9 and UNZIP 5.0p1 from any site which archives 
comp.sources.misc.



Beginning Windows programmers may wish to snarf the code that makes up the Status 
window. Heck, I wish I'd had some of that code before now.

The Unzip To... dialog box is a customized common dialog for changing directories. Check it 
out.



Warranty or Lack Thereof

I make no promises express or implied on the suitability of this software product for any 
particular purpose. 

All responsibility for use of WizUnZip lies with the user.

Robert A. Heath



History

Unzip Versions
Version Date Contributor(s)
v1.2 15 Mar 89 Samuel H. Smith
v2.0 9 Sep 89 Samuel H. Smith
v2.x fall 1989 many Usenet contributors
v3.0 1 May 90 Info-ZIP (DPK, consolidator)
v3.1 15 Aug 90 Info-ZIP (DPK, consolidator)
v4.0 1 Dec 90 Info-ZIP (GRR, maintainer)
v4.1 12 May 91 Info-ZIP
v4.2 20 Mar 92 Info-ZIP (zip-bugs subgroup; GRR, maint.)
v5.0 21 Aug 92 Info-ZIP (zip-bugs subgroup; GRR, maint.)

WizUnZip versions
Date Version Description
Jan. 27, 1992 1.0 Original Release.
Apr. 26, 1992 1.1 Fixes problem in LF to CR,LF 

mapping. Renamed "Translate LF 
to CR,LF" option to "Translate 
CR,LF to LF". 
Release of source.

June 30, 1992 1.2 Updated to Unzip 5.0 source and MS Windows 3.1
Added drag-drop, sped up zip operations, and
hiding status window.

August, 1992 1.3 Tidied up bugs in 1.2 version.

May 21, 1993 2.0 Release of WizUnZip 2.0 Beta 1.
Aligned with unzip 5.0p1,
for pkzip 2.04 compatibility.
Fixed many bugs in Windows interface.
Changed "Translate CR,LF to LF" feature
back to "Translate LF to CR,LF.".
New features: configurable "unzip to" 
directory, select files by pattern, 
play wave on completion, copy status
window to clipboard, offers self-
extracting archives as a choice when
opening a file. Moved initialization 
data to WIZUNZIP.INI. 
Thanks to Richard
Hartman for some good ideas!

July 4, 1993 2.0 General release of WizUnZip 2.0.



Help Overview

WizUnZip offers three varieties of help:

WizUnZip Help Help specific to WizUnZip
Using Windows Help How to Use Windows Help in General
About WizUnZip... Version and Author



WizUnZip Help

WizUnZip has standard Windows help accessed by typing the F1 key.    This method takes 
you to WizUnZip's top help index. You may use the mouse or keyboard to select lower-level 
topics or to simply browse.

WizUnZip also has context help by which you can hit Shift-F1, producing the 
question-mark/arrow cursor. You may then select any of WizUnZip's menu items using the 
mouse or the keyboard.    Context help takes you directly to the help screen associated with 
the desired menu item.



Using Windows Help

This menu entry takes you to the standard introduction on using Windows help.



About WizUnZip...

The about box gives the latest program version number and information about the authors.



Bugs

WizUnZip has a few bugs with some workarounds.

Archive Directory Listbox holds up to 64K bytes of data.
This problem is signaled by a Message Box which signals that the listbox has run out of 
space, due to a limitation in Windows. 
Switching to the Short Format can help if the file directory is barely big enough to fit.

Open Dialog Box Can't Distinguish Between Self-extracting .EXE's and 
Ordinary .EXE's
When listing self-extracting files, the Open dialog box lists all .EXE files regardless of whether
they are self-extracting .ZIP files.    
If you open the file and receive the "End-of-central-directory signature not found" message, 
you may assume the file is not a self-extracting .ZIP.

Status Window Displays Windows ANSI Character Set
When displaying a .ZIP file comment in the Status Window, WizUnZip maps the data into the 
ANSI Character Set


